Detail of the relationship some

Dicas do Oracle Forms Builder - Blocos, Itens, LOV, Canvas, Triggers, comandos, PLL, d2kwutil, FMB, Alert, menus, etc
  

Poston Thu, 18 Aug 2016 8:51 am

Good day gentlemen.

I have the forms 6i ... when I create 2 blocks, master and detail. The detail has 5 lines ... well, is occurring, when do I make the query on the master block, fine, shows the information of 2 blocks, however, when I click on the detail block (in any row other than the 1°), add all information. Oh I have to go in with the query (f7, f8) to show the information.
.. If you perform the query and click on the detail line 1°, there remain records can navigate normally through fields.
I'vê made several changes in RELATIONS but I have no idea what parameter move.

Thank you
Pablo
Location: 88350000

Pablo

Poston Thu, 18 Aug 2016 4:09 pm

good afternoon Pablo.

See if these relationship changes you made were not TRIGGERS unnecessary blocks.

My blocks are with the same relationship to the annex.
Attachments
relacionamento.JPG
tela de relacionamento
spernega
Location: São Paulo - SP

Poston Mon, 22 Aug 2016 2:59 pm

Hello spernega.

as it is, is equal to its annex.
As the trigger is created (automatically) the trigger ON-POPULATE-MASTER and CHECK-DELETE-MASTER. All 2 trigger, I made changes (commenting the codes) and still get the problem.
What I noticed was that, if you create a detail of 3 related tables happens the problem.
(for example: CAD_TRANSPORTADORA (has 1 record) |
CAD_PESOS_ATENDIDOS_TRANSP (holds 5 records) |
CAD_TAXAS_TRANSPORTADORA_POR_PESO (has 5 registration line)) Then, in the creation of the detail of the last table, starts the " the last 2 blocks " popping up.
Pablo
Location: 88350000

Pablo

Poston Mon, 22 Aug 2016 3:41 pm

Pablo, It has all the dirt even looking.

Do you want to send the FORMS to take a look?

Anyone who knows anything.
spernega
Location: São Paulo - SP

Poston Wed, 24 Aug 2016 1:59 pm

Paints of dirt is good ... kkkkk ... beleza, all attached Thanks
Pablo
Location: 88350000

Pablo

Poston Thu, 25 Aug 2016 10:32 am

Good day Pablo, I couldn't access the attachment.
spernega
Location: São Paulo - SP

Poston Fri, 26 Aug 2016 1:27 pm

I will try to novamente...se doesn't work, send an email to me (ti@vinculobasic.com.br) to send you the file. If we are unable to solve post here what was the magic " ";; lol
Pablo
Location: 88350000

Pablo

Poston Fri, 26 Aug 2016 1:37 pm

Closed, I say.
spernega
Location: São Paulo - SP

Poston Mon, 29 Aug 2016 11:06 am

Hello guys.
The great friend spernega found the problem. What happened is that the name of the RELATION was equal to the block name, renaming the RELATION the problem resolves.

Big hug to all.
Pablo
Location: 88350000

Pablo



Return to Forms

Who is online

Users browsing this forum: Bing [Bot] and 6 guests